using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<Date>[\d\/]+)\s*(?<Reason>\w+)\s*(?<ReferalFrom>\w+\s\w+)\s*(?<ReferalTo>\S+)\s*(?<Speciality>\w+\s\w+)\s*(?<StartDate>[\d\/]+)\s*(?<EndDate>[\d\/]+)\s(?<Allowed>\d+)";
string input = @"5/20/2022 PT AUTH PENDING Gupta,Saroj Sports Medici 05/20/2022 05/20/2023 0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}