import Foundation
let pattern = #"(?<Date>[\d\/]+)\s*(?<Reason>\w+)\s*(?<ReferalFrom>\w+\s\w+)\s*(?<ReferalTo>\S+)\s*(?<Speciality>\w+\s\w+)\s*(?<StartDate>[\d\/]+)\s*(?<EndDate>[\d\/]+)\s(?<Allowed>\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"5/20/2022 PT AUTH PENDING Gupta,Saroj Sports Medici 05/20/2022 05/20/2023 0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)