#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(?>(?<protocol>[[:alpha:]]+(?>\:[[:alpha:]]+)*)\:\/\/)?(?<host>(?>[[:alnum:]]|[-_.])+)(?>\:(?<port>[[:digit:]]+))?(?<path>\/(?>[[:alnum:]]|[-_.\/])*)?(?>\?(?<request>(?>[[:alnum:]]+=[[:alnum:]]+)(?>\&(?>[[:alnum:]]+=[[:alnum:]]+))*))?$"
Local $sString = "dmz-domaine" & @CRLF & _
"dmz-domaine:8080" & @CRLF & _
"dmz-domaine.info:8080" & @CRLF & _
"dmz-domaine.info:8080/" & @CRLF & _
"dmz-domaine.info:8080/repo" & @CRLF & _
"dmz-domaine.info:8080/repo?x=8" & @CRLF & _
"dmz-domaine.info:8080/repo?x=8&y=10" & @CRLF & _
"jdbc://dmz-domaine.info:8080/repo?x=8&y=10" & @CRLF & _
"jdbc:hsqldb:hsql://dmz-domaine.info:8080/repo?x=8&y=10" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")