import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>(?<protocol>[[:alpha:]]+(?>\\:[[:alpha:]]+)*)\\:\\/\\/)?(?<host>(?>[[:alnum:]]|[-_.])+)(?>\\:(?<port>[[:digit:]]+))?(?<path>\\/(?>[[:alnum:]]|[-_.\\/])*)?(?>\\?(?<request>(?>[[:alnum:]]+=[[:alnum:]]+)(?>\\&(?>[[:alnum:]]+=[[:alnum:]]+))*))?$";
final String string = "dmz-domaine\n"
+ "dmz-domaine:8080\n"
+ "dmz-domaine.info:8080\n"
+ "dmz-domaine.info:8080/\n"
+ "dmz-domaine.info:8080/repo\n"
+ "dmz-domaine.info:8080/repo?x=8\n"
+ "dmz-domaine.info:8080/repo?x=8&y=10\n"
+ "jdbc://dmz-domaine.info:8080/repo?x=8&y=10\n"
+ "jdbc:hsqldb:hsql://dmz-domaine.info:8080/repo?x=8&y=10\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}