$re = '/^(?>(?<protocol>[[:alpha:]]+(?>\:[[:alpha:]]+)*)\:\/\/)?(?<host>(?>[[:alnum:]]|[-_.])+)(?>\:(?<port>[[:digit:]]+))?(?<path>\/(?>[[:alnum:]]|[-_.\/])*)?(?>\?(?<request>(?>[[:alnum:]]+=[[:alnum:]]+)(?>\&(?>[[:alnum:]]+=[[:alnum:]]+))*))?$/um';
$str = 'dmz-domaine
dmz-domaine:8080
dmz-domaine.info:8080
dmz-domaine.info:8080/
dmz-domaine.info:8080/repo
dmz-domaine.info:8080/repo?x=8
dmz-domaine.info:8080/repo?x=8&y=10
jdbc://dmz-domaine.info:8080/repo?x=8&y=10
jdbc:hsqldb:hsql://dmz-domaine.info:8080/repo?x=8&y=10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);