#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,3}(,\d{3})*$"
Local $sString = "42" & @CRLF & _
"1,234" & @CRLF & _
"6,368,745" & @CRLF & _
"6,368,745,123" & @CRLF & _
"12,34,567" & @CRLF & _
"123233" & @CRLF & _
"999999999,999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")