const regex = /^\d{1,3}(,\d{3})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,3}(,\\d{3})*$', 'gm')
const str = `42
1,234
6,368,745
6,368,745,123
12,34,567
123233
999999999,999
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}