$re = '/^\d{1,3}(,\d{3})*$/m';
$str = '42
1,234
6,368,745
6,368,745,123
12,34,567
123233
999999999,999
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);