# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/[^>]+>|<[^\\/]+\\/>)\n*/$1\n/g;t' <<< "
<div class=\"ati aact\">ipsum</div><div class=\"ati\">lorem</div>
<br/>
<div class=\"ati\">dolor</div>
"