re = /(<\/[^>]+>|<[^\/]+\/>)\n*/
str = '
<div class="ati aact">ipsum</div><div class="ati">lorem</div>
<br/>
<div class="ati">dolor</div>
'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result