import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\/[^>]+>|<[^\\/]+\\/>)\\n*";
final String string = "\n\n"
+ "<div class=\"ati aact\">ipsum</div><div class=\"ati\">lorem</div>\n\n\n"
+ "<br/>\n\n\n"
+ "<div class=\"ati\">dolor</div>\n\n\n";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}