import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<code(?:\\s[^>]*)?>[\\s\\S]*?<\\/code>|`{3}([\\S\\s]*?)`{3}|`([^`]*)`|~~([\\S\\s]*?)~~|\\*{2}([\\s\\S]*?)\\*{2}(?!\\*)|\\*([^*]*)\\*|__([\\s\\S]*?)__";
final String string = "**bold and \n"
+ "*italic and \n"
+ "__underline and \n"
+ "~~strikethrough~~__***\n\n"
+ "`~~Not strikethrough~~`\n"
+ "~~`Strikethrough`~~\n\n"
+ "Normal text\n\n"
+ "```\n"
+ "~~Not strikethrough~~\n"
+ "```\n\n"
+ "~~```\n"
+ "Strikethrough\n"
+ "```~~\n\n"
+ "**bold and \n"
+ "*italic and \n"
+ "__underline and \n"
+ "~~strikethrough~~__***\n\n"
+ "`~~Not strikethrough~~`\n"
+ "~~`Strikethrough`~~\n\n"
+ "Normal text\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}