use strict;
my $str = '**bold and
*italic and
__underline and
~~strikethrough~~__***
`~~Not strikethrough~~`
~~`Strikethrough`~~
Normal text
```
~~Not strikethrough~~
```
~~```
Strikethrough
```~~
**bold and
*italic and
__underline and
~~strikethrough~~__***
`~~Not strikethrough~~`
~~`Strikethrough`~~
Normal text
';
my $regex = qr/<code(?:\s[^>]*)?>[\s\S]*?<\/code>|`{3}([\S\s]*?)`{3}|`([^`]*)`|~~([\S\s]*?)~~|\*{2}([\s\S]*?)\*{2}(?!\*)|\*([^*]*)\*|__([\s\S]*?)__/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}