$re = '/<code(?:\s[^>]*)?>[\s\S]*?<\/code>|`{3}([\S\s]*?)`{3}|`([^`]*)`|~~([\S\s]*?)~~|\*{2}([\s\S]*?)\*{2}(?!\*)|\*([^*]*)\*|__([\s\S]*?)__/m';
$str = '**bold and
*italic and
__underline and
~~strikethrough~~__***
`~~Not strikethrough~~`
~~`Strikethrough`~~
Normal text
```
~~Not strikethrough~~
```
~~```
Strikethrough
```~~
**bold and
*italic and
__underline and
~~strikethrough~~__***
`~~Not strikethrough~~`
~~`Strikethrough`~~
Normal text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);