const regex = /^ldaps?:\/\/([^\/\s]+)\/([^\/\s]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ldaps?:\\\/\\\/([^\\\/\\s]+)\\\/([^\\\/\\s]+)$', 'gm')
const str = `// expected to be OK
ldap://ldap.company.com/ou=people,dc=company,dc=com
ldaps://ldap.company.com/ou=people,dc=company,dc=com
ldaps://localhost:636/dc=localhost
ldaps://ldap.company.com/foo
// expected to be NG
ldap.company.com/ou=people,dc=company,dc=com
ldaps:///ou=people,dc=company,dc=com
ldap://ldap.company.com/ou=people,dc=company,dc=com/
ldaps://ldap.company.com/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}