$re = '/^ldaps?:\/\/([^\/\s]+)\/([^\/\s]+)$/m';
$str = '// expected to be OK
ldap://ldap.company.com/ou=people,dc=company,dc=com
ldaps://ldap.company.com/ou=people,dc=company,dc=com
ldaps://localhost:636/dc=localhost
ldaps://ldap.company.com/foo
// expected to be NG
ldap.company.com/ou=people,dc=company,dc=com
ldaps:///ou=people,dc=company,dc=com
ldap://ldap.company.com/ou=people,dc=company,dc=com/
ldaps://ldap.company.com/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);