re = /^ldaps?:\/\/([^\/\s]+)\/([^\/\s]+)$/m
str = '// expected to be OK
ldap://ldap.company.com/ou=people,dc=company,dc=com
ldaps://ldap.company.com/ou=people,dc=company,dc=com
ldaps://localhost:636/dc=localhost
ldaps://ldap.company.com/foo
// expected to be NG
ldap.company.com/ou=people,dc=company,dc=com
ldaps:///ou=people,dc=company,dc=com
ldap://ldap.company.com/ou=people,dc=company,dc=com/
ldaps://ldap.company.com/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end