package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)\s+(\w{5})\s+(.+)\s+(\$[\d.]+)`)
var str = `Qty. Model Code Instrument/department/model/Vision Make&Model,etc. T&A Charge
82 34ARE Guitar bag $154
22 A4314 play Bag and zipper $409.80`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}