use strict;
my $str = 'Qty. Model Code Instrument/department/model/Vision Make&Model,etc. T&A Charge
82 34ARE Guitar bag $154
22 A4314 play Bag and zipper $409.80';
my $regex = qr/(\d+)\s+(\w{5})\s+(.+)\s+(\$[\d.]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}