using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[AB]*[CD][AB]*$).{4}$";
string input = @"ABCD
AAAA
AAAD
AAAB
BBDA
CCCC
CCCA
DADA
BABC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}