$re = '/^(?=[AB]*[CD][AB]*$).{4}$/m';
$str = 'ABCD
AAAA
AAAD
AAAB
BBDA
CCCC
CCCA
DADA
BABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);