re = /^(?=[AB]*[CD][AB]*$).{4}$/m
str = 'ABCD
AAAA
AAAD
AAAB
BBDA
CCCC
CCCA
DADA
BABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end