import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?msi)^step start(?:(?!^step start).)*?database:dev.*?step end";
final String string = "step start\n"
+ " name:step1\n"
+ " database:dev1\n"
+ "step end\n"
+ "step start\n"
+ " name:step2\n"
+ " database:test1\n"
+ "step end\n"
+ "step start\n"
+ " name:step3\n"
+ " database:dev2\n"
+ "step end\n"
+ "step start\n"
+ " name:step4\n"
+ " database:test2\n"
+ "step end";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}