const regex = /(?msi)^step start(?:(?!^step start).)*?database:dev.*?step end/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?msi)^step start(?:(?!^step start).)*?database:dev.*?step end', 'gsm')
const str = `step start
name:step1
database:dev1
step end
step start
name:step2
database:test1
step end
step start
name:step3
database:dev2
step end
step start
name:step4
database:test2
step end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}