import re
regex = re.compile(r"(?msi)^step start(?:(?!^step start).)*?database:dev.*?step end", flags=re.DOTALL | re.MULTILINE)
test_str = ("step start\n"
" name:step1\n"
" database:dev1\n"
"step end\n"
"step start\n"
" name:step2\n"
" database:test1\n"
"step end\n"
"step start\n"
" name:step3\n"
" database:dev2\n"
"step end\n"
"step start\n"
" name:step4\n"
" database:test2\n"
"step end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")