import re
regex = re.compile(r"^\w+:\K\w.*", flags=re.MULTILINE)
test_str = ("this string should not match\n\n"
"bob_1:Hi. I'm Bob. I speak русский and this string should match \n\n"
"alice:Hi Bob. I speak 한국어 and this string should also match\n\n"
"http://example.com - would prefer to not match URLs\n\n"
"This string:should not match because no spaces or capital letters are allowed left of the colon")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")