re = /^\w+:\K\w.*/m
str = 'this string should not match
bob_1:Hi. I\'m Bob. I speak русский and this string should match
alice:Hi Bob. I speak 한국어 and this string should also match
http://example.com - would prefer to not match URLs
This string:should not match because no spaces or capital letters are allowed left of the colon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end