package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)vertex.+\s[0-9\.]*[1-9][0-9\.]*$`)
var str = `facet normal -1.000000 0.000000 0.000000
outer loop
vertex 26.000000 6.000000 0.000000
vertex 26.000000 6.000000 -1.000000
vertex 26.000000 7.000000 1.000000
endloop
endfacet
facet normal -1.000000 0.000000 0.000000
outer loop
vertex 26.000000 6.000000 0.000000
vertex 26.000000 7.000000 1.000000
vertex 26.000000 7.000000 0.000000
endloop
endfacet
facet normal 0.000000 1.000000 0.000000
outer loop
vertex 26.000000 7.000000 0.000100
vertex 26.000000 7.000000 1.000000
vertex 27.000000 7.000000 1.000000
endloop
endfacet
endsolid `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}