import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "vertex.+\\s[0-9\\.]*[1-9][0-9\\.]*$";
final String string = "facet normal -1.000000 0.000000 0.000000\n"
+ "outer loop\n"
+ "vertex 26.000000 6.000000 0.000000\n"
+ "vertex 26.000000 6.000000 -1.000000\n"
+ "vertex 26.000000 7.000000 1.000000\n"
+ "endloop\n"
+ "endfacet\n"
+ "facet normal -1.000000 0.000000 0.000000\n"
+ "outer loop\n"
+ "vertex 26.000000 6.000000 0.000000\n"
+ "vertex 26.000000 7.000000 1.000000\n"
+ "vertex 26.000000 7.000000 0.000000\n"
+ "endloop\n"
+ "endfacet\n"
+ "facet normal 0.000000 1.000000 0.000000\n"
+ "outer loop\n"
+ "vertex 26.000000 7.000000 0.000100\n"
+ "vertex 26.000000 7.000000 1.000000\n"
+ "vertex 27.000000 7.000000 1.000000\n"
+ "endloop\n"
+ "endfacet\n"
+ "endsolid ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}