package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)first=([^&]*)`)
var str = `http://www.example.com.tr/?first=DSPN47ZTE1BGMR&second=NECEFT8RYD
http://www.example.com.tr/?first=RTR22414242144&second=YUUSADASFF
http://www.example.com.tr/?first=KOSDFASEWQESAS&second=VERERQWWFA
http://www.example.com.tr/?first=POLUJYUSD41234&second=13F241DASD
http://www.example.com.tr/?first=54SADFD14242RD&second=TYY42412DD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}