import re
regex = re.compile(r"first=([^&]*)", flags=re.MULTILINE)
test_str = ("http://www.example.com.tr/?first=DSPN47ZTE1BGMR&second=NECEFT8RYD\n"
"http://www.example.com.tr/?first=RTR22414242144&second=YUUSADASFF\n"
"http://www.example.com.tr/?first=KOSDFASEWQESAS&second=VERERQWWFA\n"
"http://www.example.com.tr/?first=POLUJYUSD41234&second=13F241DASD\n"
"http://www.example.com.tr/?first=54SADFD14242RD&second=TYY42412DD")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")