#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\+66|0)(\d{1,2}\-?\d{3}\-?\d{3,4}))|((\+๖๖|๐)([๐-๙]{1,2}\-?[๐-๙]{3}\-?[๐-๙]{3,4}))"
Local $sString = "065-963-9928" & @CRLF & _
"088-992-6492" & @CRLF & _
"065-9926492" & @CRLF & _
"0659926492" & @CRLF & _
"02-700-9099" & @CRLF & _
"02-7009099" & @CRLF & _
"027009099" & @CRLF & _
"+66889926492" & @CRLF & _
"0212345678910" & @CRLF & _
"" & @CRLF & _
"088-9926492" & @CRLF & _
"02-99264923" & @CRLF & _
"02-992-64923" & @CRLF & _
"" & @CRLF & _
"๐๒๙๙๖๔๙๒๓" & @CRLF & _
"๐๒-๙๙๖-๔๙๒๓" & @CRLF & _
"๐๒-๙๙๖๔๙๒๓" & @CRLF & _
"" & @CRLF & _
"๐๘๘๙๙๖๔๙๒๓" & @CRLF & _
"๐๘๘-๙๙๖๔๙๒๓" & @CRLF & _
"๐๘๘-๙๙๖-๔๙๒๓" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")