import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\+66|0)(\\d{1,2}\\-?\\d{3}\\-?\\d{3,4}))|((\\+๖๖|๐)([๐-๙]{1,2}\\-?[๐-๙]{3}\\-?[๐-๙]{3,4}))";
final String string = "065-963-9928\n"
+ "088-992-6492\n"
+ "065-9926492\n"
+ "0659926492\n"
+ "02-700-9099\n"
+ "02-7009099\n"
+ "027009099\n"
+ "+66889926492\n"
+ "0212345678910\n\n"
+ "088-9926492\n"
+ "02-99264923\n"
+ "02-992-64923\n\n"
+ "๐๒๙๙๖๔๙๒๓\n"
+ "๐๒-๙๙๖-๔๙๒๓\n"
+ "๐๒-๙๙๖๔๙๒๓\n\n"
+ "๐๘๘๙๙๖๔๙๒๓\n"
+ "๐๘๘-๙๙๖๔๙๒๓\n"
+ "๐๘๘-๙๙๖-๔๙๒๓\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}