# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\+66|0)(\d{1,2}\-?\d{3}\-?\d{3,4}))|((\+๖๖|๐)([๐-๙]{1,2}\-?[๐-๙]{3}\-?[๐-๙]{3,4}))"
test_str = ("065-963-9928\n"
"088-992-6492\n"
"065-9926492\n"
"0659926492\n"
"02-700-9099\n"
"02-7009099\n"
"027009099\n"
"+66889926492\n"
"0212345678910\n\n"
"088-9926492\n"
"02-99264923\n"
"02-992-64923\n\n"
"๐๒๙๙๖๔๙๒๓\n"
"๐๒-๙๙๖-๔๙๒๓\n"
"๐๒-๙๙๖๔๙๒๓\n\n"
"๐๘๘๙๙๖๔๙๒๓\n"
"๐๘๘-๙๙๖๔๙๒๓\n"
"๐๘๘-๙๙๖-๔๙๒๓\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.