import re
regex = re.compile(r"^(?:(?:\(?(?:00|\+)([1-4]\d\d|[1-9]\d?)\)?)?[\-\.\ \\\/]?)?((?:\(?\d{1,}\)?[\-\.\ \\\/]?){0,})(?:[\-\.\ \\\/]?(?:#|ext\.?|extension|x)[\-\.\ \\\/]?(\d+))?$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("(+44) 7 9349394 349893\n"
"07810640611\n"
"+447542156663\n"
"0162611111\n"
"01245\n"
"01 265 457 789 1 11\n"
"sgrxdrxg dr\n"
"7498ghdxrg\n"
"78974756456451321546547984645")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")