re = /^(?:(?:\(?(?:00|\+)([1-4]\d\d|[1-9]\d?)\)?)?[\-\.\ \\\/]?)?((?:\(?\d{1,}\)?[\-\.\ \\\/]?){0,})(?:[\-\.\ \\\/]?(?:#|ext\.?|extension|x)[\-\.\ \\\/]?(\d+))?$/im
str = '(+44) 7 9349394 349893
07810640611
+447542156663
0162611111
01245
01 265 457 789 1 11
sgrxdrxg dr
7498ghdxrg
78974756456451321546547984645'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end