$re = '/((?<=\s)(, ))/';
$str = ' , BE 11 BE 16, BE 19, BE 11, 15 ECTS, S2, 105 ECTS, 132 ECTS';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);