import re
regex = re.compile(r"((?<=\s)(, ))")
test_str = " , BE 11 BE 16, BE 19, BE 11, 15 ECTS, S2, 105 ECTS, 132 ECTS"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")