import Foundation
let pattern = #"((?<=\s)(, ))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" , BE 11 BE 16, BE 19, BE 11, 15 ECTS, S2, 105 ECTS, 132 ECTS"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}