package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:all\s)?right\b`)
var str = `This is a test with both all right and right in it. Please don't match this false rright or this aall right, also don't match this all rightt.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}