const regex = /\b(?:all\s)?right\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:all\\s)?right\\b', 'gm')
const str = `This is a test with both all right and right in it. Please don't match this false rright or this aall right, also don't match this all rightt.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}