$re = '/\b(?:all\s)?right\b/m';
$str = 'This is a test with both all right and right in it. Please don\'t match this false rright or this aall right, also don\'t match this all rightt.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);