#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\*\*Node[\s\S]*?(?=\*End Instance)"
Local $sString = "** ASSEMBLY" & @CRLF & _
"**" & @CRLF & _
"*Assembly, name=Assembly" & @CRLF & _
"** " & @CRLF & _
"*Instance, name=Part-1-1, part=Part-1" & @CRLF & _
"*Node" & @CRLF & _
"**Node" & @CRLF & _
"1, 12., 0." & @CRLF & _
"2, 12., -6." & @CRLF & _
"3, 9., -15." & @CRLF & _
"4, 7.99721575, -53." & @CRLF & _
"** Section: t3" & @CRLF & _
"*Shell Section, elset=Set-3, material=PET" & @CRLF & _
"2., 5" & @CRLF & _
"** Section: t4" & @CRLF & _
"*Shell Section, elset=Set-4, material=PET" & @CRLF & _
"2., 5" & @CRLF & _
"*End Instance" & @CRLF & _
"** " & @CRLF & _
"*End Assembly" & @CRLF & _
"** " & @CRLF & _
"** MATERIALS" & @CRLF & _
"** " & @CRLF & _
"*Material, name=PET"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")