re = /\*\*Node[\s\S]*?(?=\*End Instance)/m
str = '** ASSEMBLY
**
*Assembly, name=Assembly
**
*Instance, name=Part-1-1, part=Part-1
*Node
**Node
1, 12., 0.
2, 12., -6.
3, 9., -15.
4, 7.99721575, -53.
** Section: t3
*Shell Section, elset=Set-3, material=PET
2., 5
** Section: t4
*Shell Section, elset=Set-4, material=PET
2., 5
*End Instance
**
*End Assembly
**
** MATERIALS
**
*Material, name=PET'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end