import re
regex = re.compile(r"\*\*Node[\s\S]*?(?=\*End Instance)", flags=re.MULTILINE)
test_str = ("** ASSEMBLY\n"
"**\n"
"*Assembly, name=Assembly\n"
"** \n"
"*Instance, name=Part-1-1, part=Part-1\n"
"*Node\n"
"**Node\n"
"1, 12., 0.\n"
"2, 12., -6.\n"
"3, 9., -15.\n"
"4, 7.99721575, -53.\n"
"** Section: t3\n"
"*Shell Section, elset=Set-3, material=PET\n"
"2., 5\n"
"** Section: t4\n"
"*Shell Section, elset=Set-4, material=PET\n"
"2., 5\n"
"*End Instance\n"
"** \n"
"*End Assembly\n"
"** \n"
"** MATERIALS\n"
"** \n"
"*Material, name=PET")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")