import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9]*[2468]|0*[1-9][0-9]*[02468])$";
final String string = "2\n"
+ "001234\n"
+ "00123400\n"
+ "002\n"
+ "20\n"
+ "16\n"
+ "0\n"
+ "0000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}