$re = '/^(?:[0-9]*[2468]|0*[1-9][0-9]*[02468])$/m';
$str = '2
001234
00123400
002
20
16
0
0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);