re = /^(?:[0-9]*[2468]|0*[1-9][0-9]*[02468])$/m
str = '2
001234
00123400
002
20
16
0
0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end