const regex = new RegExp('^([a-z]+-[a-z]+[0-9]+-[a-z]+)$|^([a-z]+[0-9]+-[a-z]+[0-9]+-[a-z])$|^([a-z]+-[a-z]+-[a-z])$', 'gmi')
const str = `aaa-b3-c
a3-b6-c
aaaa-bb-c
aaa-b3-c3
a3-1b6-c
aaaa-bb-c7`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);