$re = '/^([a-z]+-[a-z]+[0-9]+-[a-z]+)$|^([a-z]+[0-9]+-[a-z]+[0-9]+-[a-z])$|^([a-z]+-[a-z]+-[a-z])$/mi';
$str = 'aaa-b3-c
a3-b6-c
aaaa-bb-c
aaa-b3-c3
a3-1b6-c
aaaa-bb-c7';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;